Une des méthodes les plus simples pour installer Joomla! sur un serveur distant est d'utiliser soit le zip du pack d'installation et kickstart.php d'Akeeba backup, soit JInstaller.

La première méthode a l'avantage de ne demander le transfert par ftp que de trois fichiers (le pack de Joomla! compressé, le fichier kickstart.php et son fichier de langue). La seconde utilise 6 fichiers et deux dossiers.

JInstaller n'étant plus disponible sur le JED (extensions.joomla.org), ni sur le site des extensions en français (extensions.joomla.fr), je me suis permis d'adapter une ancienne version pour la mettre ici à votre disposition (lien de téléchargement plus bas).

29 août 2016 : Une méthode encore plus simple est maintenant disponible : GetJoomla FR, qui permet d'installer Joomla! en version francophone bien plus facilement encore qu'avec JInstaller, puisqu'il suffit de transférer un seul fichier index.php vers le serveur. Les explications sont disponibles sur cette page et le téléchargement ici.

L'utilisation de JInstaller est simple : après avoir décompressé le pack en local, vous obtiendrez deux dossiers et un fichier "jinstaller.php". Transférez par ftp (avec FileZilla par exemple) ce contenu dans le dossier du serveur distant destiné à recevoir le site, puis saisissez l'adresse d'accès au futur site, suivie de "/jinstaller.php" (exemple "http://mondomaine.tld/jinstaller.php"). Le script téléchargera alors la version de Joomla! à installer et la décompressera sur votre serveur, puis vous signalera que vous pouvez supprimer du serveur les fichiers et dossiers de JInstaller, l'étape suivante étant l'installation de Joomla! pour laquelle vous aurez besoin de disposer des informations d'accès à la base de données que devra utiliser votre site.

La version disponible ce jour (05/08/2016) vous proposera Joomla! 3.6.2 (francophone) pour une version de PHP au moins égale à 5.3.10, la version francophone étant celle proposée par l'équipe de Joomla.fr :

Cerre version a été testée sur des PHP 5.3.10+, 5.4, 5.5, 5.6 et 7 sachant que les versions 3.3+ nécessitent au moins PHP 5.3.10

Attention ! Si Joomla! 3.6.2 est compatible avec PHP 7, toutes les extensions ne le sont pas encore nécessairement, donc prudence si vous souhaitez passer en PHP 7.